Jump to content
yoyo2611

armement impossible

Recommended Posts

salut a tous 

voila j ai sortie le drone de la cave ^^ un wizard x220s 
ça fait 6/7 mois que je m en suis pas servie du coup mise jour de la carte OMNIBUSF4SD 
du coup je refait les réglage
dans "mode" puis "arm" ne s active pas en jaune 

 

 

arm.png

config.png

recepteur.png

Share this post


Link to post
Share on other sites
Posted (edited)

oui tout bouge 
quand j active l armement le drone sonne comme si il été armer  mais je sait plus la différence de sonnerie entre armement et désarmement   
juste avant de faire la maj tout fonctionner 

Edited by yoyo2611

Share this post


Link to post
Share on other sites

Salut,

Ça peut être pas mal de choses, pré-armement, ton drone n'est pas à plat,...

Tu peux regarder cette vidéo, elle est assez complète et fait le tour des problèmes qu'on peut rencontrer concernant l'armement (même si ta version de Betaflight est plus récente) :

 

 

Blutch.

Share this post


Link to post
Share on other sites
Posted (edited)

re

c'est quoi ce message j ai écrit pareil sur le CLI

MCU F40X Clock=168MHz (PLLP-HSE), Vref=3.30V, Core temp=42degC
Stack size: 2048, Stack address: 0x1000fff0
Config size: 3061, Max available config: 16384
GYRO=MPU6000, ACC=MPU6000, BARO=BMP280
System Uptime: 351 seconds, Current Time: 2019-05-14T12:42:28.156+00:00
CPU:8%, cycle time: 126, GYRO rate: 7936, RX rate: 129, System rate: 9
Voltage: 1 * 0.01V (0S battery - NOT PRESENT)
I2C Errors: 0
SD card: None inserted
Arming disable flags: CLI MSP ARMSWITCH

 

 

instalation.png

Edited by yoyo2611

Share this post


Link to post
Share on other sites

Ça veut dire qu'il y a 3 choses qui empêchent l'armement : CLI, MSP et ARMSWITCH

CLI : tu ne peux pas armer depuis la console

MSP : tu es connecté à Betaflight

ARMSWITCH : l'interrupteur (celui utilisé pour l'ARM) n'est pas dans la bonne position

Tu peux retrouver les info dans le wiki https://github.com/betaflight/betaflight/wiki/Arming-Sequence-&-Safety

Share this post


Link to post
Share on other sites

Je viens de vérifier. Sous bétaflight avec ma carte omnibus f4, je suis sous le firmware 3.5.1 

Je ne peux pas armer les moteurs quand je suis connecté à betaflight, dès l'instant que je déconnecte, les moteurs tournent. 

Donc essaye EN ENLEVANT LES HÉLICES, tu déconnectes betaflight (tu peux laisser l'usb branché ça ne gêne pas si tu es déconnecté). Tu branches la batterie et tu armes, ça devrait fonctionner

Maintenant, si , quand tu es connecté à betaflight, tu bascules ton aux 1 sur "moteurs désarmés". Quand tu vas dans cli et que tu tapes "status", tu ne devrais voir en dernieère ligne Arming disable flags: CLI MSP

Share this post


Link to post
Share on other sites

c'est bon sa marche j ai mis en 3.5.7
à partir de la 4.0.0 le drone fait complètement de la merde il accélère tout seul et impossible de redescendre les gaz
après dans récepteur "manche en haut" si tu monte plus qu'a 1900 sa ne arme plus les moteur pareil si tu descend à moins de 1050 dans "manche en bas"
et dans modes, si tu a le malheurs de vouloir un bouton pour armer les moteur ça marche pas non plus, faut le laisser avec le joystick "bas droit" 

ça ma bien gonfler cette histoire merci a vous
 

Share this post


Link to post
Share on other sites

tout est normal ===> que les moteurs accélèrent tout seul quand il n'y a pas d"hélice c'est parce qu'il essaye de se remettre a plat, donc il compense et , comme rien ne se passe,il accélère et ainsi de suite. Tu peux remettre les hélices et aller voler ça volera normalement. 

concernant les valeurs citées c'est normal aussi en dessous de 1050, pas assez de jus pour que les moteurs tournent...... 

tu as essayé le bouton d'armement en deconnectant betaflight ? ça devrait fonctionner aussi 

 

 

Share this post


Link to post
Share on other sites
il y a 38 minutes, yoyo2611 a dit :

si tu monte plus qu'a 1900 sa ne arme plus les moteur

Ben heureusement que ça n'arme pas, sinon ça te ferait tout drôle... 😁

Pour la valeur mini des gaz, tu peux l'ajuster, mais dans une certaine mesure. Comme Arnaud l'a dit, il faut quand même un minimum de jus aux moteurs.

 

Share this post


Link to post
Share on other sites
Posted (edited)
il y a 30 minutes, the guitar hero a dit :

tout est normal ===> que les moteurs accélèrent tout seul quand il n'y a pas d"hélice c'est parce qu'il essaye de se remettre a plat, donc il compense et , comme rien ne se passe,il accélère et ainsi de suite. Tu peux remettre les hélices et aller voler ça volera normalement. 

concernant les valeurs citées c'est normal aussi en dessous de 1050, pas assez de jus pour que les moteurs tournent...... 

tu as essayé le bouton d'armement en deconnectant betaflight ? ça devrait fonctionner aussi 

 

 

quand je dit accélère tout seul c'est qu'il tourne a fond les ballon 😀 et quand je suis revenue en 3.5.7 tout fonctionne nickel 

oui j ai essayer sa marche pas

Edited by yoyo2611

Share this post


Link to post
Share on other sites

quelques fois certaine versions de betaflight ne passent pas avec certaines carte, ça m'est déjà arrivé. Mais je t'assure que les moteurs qui accelèrent c'est tout à fait normal. si tu te mets en mode acro et que tu désactives l'air mode, ça le fait plus

 

Share this post


Link to post
Share on other sites
Il y a 3 heures, Blutch a dit :

Ben heureusement que ça n'arme pas, sinon ça te ferait tout drôle... 😁

 

 

je parle du manche en haut

Share this post


Link to post
Share on other sites




×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.