Jump to content
cypher769

Racer250 Remplacement Cc3D Par Sp.racing.f3

Recommended Posts

bonjour,

 

voici mon problème, j'ai un racer250 avec une carte CC3D. pas tres satisfait de la stabilisation, j'ai décidé de la remplacer par une autre. là je choisi une sp racing f3 10 dof deluxe. c'est là que le défit commence.  :ssv:

changement de logiciel car librepilote ne gere pas les SP F3, betaflight seulement en anglais (BEURK...) interface et principe complètement différent et cerise sur le gâteaux plus de communication entre la radio commande et le contrôleur :( .

 

Bon de là je vous passe le pb de flash de la carte ... d'apparence simple mais bon je suis sous linux...enfin j'ai un double boot.

 

j'ai reussi à me depatouiller du flash, du pb de com radio avec le contrôleur de vol, grâce au forum ( merci xav pour ton aide de toujours ... souvenir de xav....). :avion-xavdrone:

 

:sos:mon pb réside maintenant dans le calibrage des moteurs. sur librepilote on peut les calibrer individuellement pour un réglage au petit oignon. je me doute que l'on peut faire la même chose ici mais je ne l'ai pas trouver.

j'ai 2 moteur sur 4 qui ne tourne pas au ralenti (ou armement) et cela implique un déséquilibre en vol qui devient complètement instable :avion: .

Dois-je flasher les ESC pour résoudre le pb?

 

désolé pour le roman mais je pense que cela vous servira pour comprendre mon PB. merci d'avance de partager votre conaissance avec un débutant comme moi. 

Edited by xavdrone

Share this post


Link to post
Share on other sites

Salut

 

Il faudrai calibrer les ESC oui, au moins voir si ce n'est qu'un simple problème de calibration ou non.

 

Donc finalement tu utilises quand même betaflight ?

 

Si c'est le cas regarde ne serai ce que le début de cette vidéo :

 

 

Et évite les abréviations stp -> voir réglement.

Share this post


Link to post
Share on other sites

Dans Betaflight, la calibration des esc de fait comme suit:

 

0) Batterie déconnectée / hélices retirées

1) Connecter le contrôleur de vol

2) dans la section motor

2.1) activer l'option en bas à droite

2.2) monter le «Master» à fond

3) connecter la batterie

3.1) attendre que les esc fassent 4 beeps

3.2) descendre le «master»

4) déconnecter la batterie

 

C'est fait

 

 

Sent from my SM-G900F using Tapatalk

Share this post


Link to post
Share on other sites

Dans Betaflight, la calibration des esc de fait comme suit:

 

0) Batterie déconnectée / hélices retirées

1) Connecter le contrôleur de vol

2) dans la section motor

2.1) activer l'option en bas à droite

2.2) monter le «Master» à fond

3) connecter la batterie

3.1) attendre que les esc fassent 4 beeps

3.2) descendre le «master»

4) déconnecter la batterie

 

C'est fait

 

 

Sent from my SM-G900F using Tapatalk

Bonjour

je rajouterai après le point 3.2 d'attendre une nouvelle fois les beeps de confirmation

avant de faire le point 4

Share this post


Link to post
Share on other sites

bonsoir,

 

avant toute chose merci pour les réponses.

 

alors dans l'ordre;

- oui j'ai déjà calibré les ESC avec le tutoriel en question (très bien le tutoriel au passage, il faut le dire). je me suis aperçu que ma batterie est morte à la charge suivante.

peut être était elle morte au moment du calibrage et qu'elle a simplement fait foirer la manœuvre?

- oui j'utilise bétaflight, mais  je le trouve pas très intuitif ni agréable en prise en main mais c'est peut être le manque de l'interface en français. de toute façon il n'y a pas d'autre logiciel que je connaisse pour ce contrôleur de vol.

 

je fais un autre essai demain en soirée. pensez -vous que la méthode de flash est en paire avec le calibrage ou n'y a-t-il aucun lien?

 

bonne soirée

Share this post


Link to post
Share on other sites

re,

 

petit complement de question, j'ai une Lipo en 4S est-elle compatible avec mon drone ou comment je le verifie?

je suis actuellement en 3S mais il semble que mon model de racer250 supporte les 4S. quel est l'élément qui limite ou calibre le nombre de cellules?

 

re bonne soirée

Share this post


Link to post
Share on other sites

bonjour,

 

desolé pour le délai de réponse. j'ai fait et refait et refait encore la calibration des ESC sans succès. j' ai toujours une instabilité qui rend le drone incontrôlable.

alors selon vous:

un eachine racer 250 cc3d ne peut-il pas recevoir en remplacement une carte SPRF3?

je pensais que les SPRF3 était plus complète au niveaux des fonctions disponibles mais il semblerait qu'elles soient assez capricieuses à la mise en route?

avez vous fait ce genre de montage?

sous librepilote ils ne parle nul part de flash des ESC, est il fait a notre insus?

 

merci de l'attention que vous portez à ce sujet et mon problème.

Share this post


Link to post
Share on other sites

bon, je viens de modifier les PIDs comme conseiller dans un autre sujet mais rien y fait.

je me demande si les 2 moteurs qui ne tourne pas au ralenti son en cause. il est possible que cela le déstabilise mais de la à le rendre incontrôlable et poussif malgré les réglages je ne vois pas.

sous librepilote on peut affiner le réglage de chaque moteur mais je sais pas comment faire sous bétaflight.

je vais aussi verifier la connection des moteur sur le transmetteur car il me semble qu'il y a une inversion de cc3d à sprf3

Share this post


Link to post
Share on other sites

Dans l'onglet moteur tes moteurs corresponde bien au schéma quand tu les bouge un pars un ! Et genre pas quand tu bouge le 3 c'est le 4 qui tourne sur betaflight ??

 

Envoyé de mon SM-G850F en utilisant Tapatalk

Share this post


Link to post
Share on other sites

Et aussi une petite question quand ton drone est brancher à l'ordi sur l'onglet principale il réagis bien du genre tu penche vers l'avant il vas vers le côté par exemple ??

 

Envoyé de mon SM-G850F en utilisant Tapatalk

Share this post


Link to post
Share on other sites

pour les réactions via l'ordi il se comporte normalement pour les directions mais je n'ai pas encore verifié si il n'y a pas d'inversion des moteurs 3 et 4 bien que je me serais apperçu au travers du contôle du comportement anormal?

Share this post


Link to post
Share on other sites

Je ne veux pas dire de bêtises mais il me semble que ce n'est pas la même connectique pour la SPracingF3 que pour la cc3d au niveau des moteurs.

C'est le grand connecteur avec tous les fils noirs qui relient la FC à la PDB, il faut en inverser certains.

Tu n'as rien trouvé sur le net à ce sujet ?

 

Envoyé de mon HTC One en utilisant Tapatalk

Share this post


Link to post
Share on other sites

bonjour,

 

premier test après les vacances...

- les moteurs correspondent bien à l'ordre et au sens de rotation.

après vérification,  j'avais modifier dans la radio commande le Roll et le Yaw, ce qui ne me convenait pas. j'ai rétablis les paramettres mais bon, je ne suis pas convaincu que le problème vienne uniquement de là.

 

- la propulsion est hasardeuse, j'ai fait un réglage au niveaux des PID's mais je pense que les données que j'ai trouvé ne sont pas bonne pour mon modèle ( P50, I40, D20). il tangue et semble en difficulté pour compenser. est-ce la raison du problème? 

 

quelqu'un a t il des PID pour un eachine racer 250 avec contrôleur SP racing F3 Hybride?

 

existe-il une appli qui règles les PID's "automatiquement" ou semi-assisté?

 

merci

Share this post


Link to post
Share on other sites

Bonjour Cypher,

 

A ma connaissance limitée, il n'y a pas de soft qui 'auto-tune' tes PID, les solutions qui existent, genre TxPID te permettent de faire des modifs 'à la volée'  (par exemple via les 'pottards' de ta RC).

 

Pour tes oscillations à l'époque sous librepilot, je modifiais les paramètres de la boucle exterieure dans le menu de droite 'stabilization' et en restant dans l'onglet 'basic' Si la valeur est trop haute le quad oscille, trop basse et on en perd le contrôle.

Share this post


Link to post
Share on other sites

Salut si moi j'ai quelque un fichier Excel qui règle les pid et donne des précision je vous mets le lien des que je rentre chez moi

 

Envoyé de mon SM-G850F en utilisant Tapatalk

Share this post


Link to post
Share on other sites

Et pour ce qui est de tes oscillations le seul moyen de régler le problème sur eachine c'est de flasher tes esc sur blheli !

 

Envoyé de mon SM-G850F en utilisant Tapatalk

Share this post


Link to post
Share on other sites

Surtout si t'es oscillations sont en mode angle et horizon ! Je suppose que sa fais sa quand tu descend en altitude

 

Envoyé de mon SM-G850F en utilisant Tapatalk

Share this post


Link to post
Share on other sites

fais ..... j'arrive pas a envoyer le lien c'est nul a quand plus d'espace pour les pièces jointes purée !!!!!!!!!!!!!

pourquoi je n'ai pas le permission d'envoyer ce fichier sa me soul l

Share this post


Link to post
Share on other sites

si tu as une adresse mail écris en MP et je te l'enverrai sinon je vois pas comment faire la ! de plus quand je cherche le fichier sur internet il me dis qu'il est plus disponible mais moi je l'ai garder 

Share this post


Link to post
Share on other sites




×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.