Jump to content
Anakroone

Carte contrôleur

Recommended Posts

Salut à tous,

J'ai une petite question, les beaux jours arrivent ( enfin presque ) j'ai donc décidé de ressortir mon eturbin.

Mais voilà j'aimerais bien remplacer ma cc3d par une carte f4, et vu le nombre qu'il y a sur le marché je reviens vers vous afin de me conseiller laquelle choisir

j'utilise une Spektrum dx8 avec un Ar6210.

Merci d'avance

Share this post


Link to post
Share on other sites

Beaucoup d'entre elles feraient parfaitement le job : Youpi F4, armattan, omnibus, betaflight, Bardwell, pyrodrone, etc...

Il faudra par contre passer par betafflight pour configurer ton appareil.

Share this post


Link to post
Share on other sites

Bon et bien je viens de recevoir une carte Controleur de Vol F4 pour Omnibus 180-250 Drone Stm32 Integrated Osd 5v Bec Flight Controller. Malgré  le schéma fourni je ne vois pas très bien comment connecter tous les fils de mon ar6210 dsmx.

Avant de cramer la carte par cause d'une mauvaise soudure qq'un pourrais m'indiquer la bonne marche à suivre, merci d'avance

61ikbd38wGL._SL1001_.jpg

Share this post


Link to post
Share on other sites

il me semble que l'ar610 est un récepteur ancienne génération en pwm, ta carte n'accepte que le ppm, sbus et ibus. il te faut un récepteur avec un de ces protocoles. Attention aux recepteurs estampillés dsm2/dsmx, ils sont souvent en dsm2 et les nouvelles radio spektrum ne sont plus qu'en dsmx

Share this post


Link to post
Share on other sites

Salut,

Les experts me corrigeront peut-être mais il me semble que ton récepteur ne peut être connecté qu'en PWM (1 câble par canal) alors que ta carte ne le prend pas en charge.

À mon avis il va falloir changer de récepteur. Un truc du genre SPM4648 ferait l'affaire (il y a une sortie 3,3v sur ta FC).

Share this post


Link to post
Share on other sites

Ok merci je m'en doutais

Du coup le mieux c'est quoi un nouveau récepteur ou un autre contrôleur compatible ?? 

Pourriez vous me conseiller histoire de plus faire d'erreur.

Ps je compte pas virer ma dx8 ☺

Merci à tous

Share this post


Link to post
Share on other sites

Chez orange et chez redcon ils font des récepteurs ppm et sbus pas chers.  Tu devrais trouver ton bonheur. Google est mon ami ;) tu les trouveras sous le protocole cppm  mais c'est la même chose que ppm. Gaffe, quand le récepteur  est estampillé dsm2 dsmx, il est en dsm2 qui est l'ancienne norme. Vérifie que ta radio soit encore compatible dsm2

Share this post


Link to post
Share on other sites

Bonjour à tous,

je reviens à nouveau vers vous car je suis bloqué avec mon TB250.

J'ai donc remplacé la carte de vol par une OmnibusF4SD avec un récepteur cm703 en ppm.

J'ai installé Betaflight, flashé la carte suivi un tuto afin d'avoir une programmation de base.

Tout à l'air de fonctionner, lorsque je connecte ma radio, dans l'onglet récepteur tous réagit correctement.

Par contre lorsque j'essaie les moteurs rien ne se passe aucun ne démarre, j'ai juste un bip discontinu en permanence.

D’où ma question les esc ( esc 12A ETB-EC1 ) que j'ai sont ceux d'origine fourni avec la cc3d, sont ils compatible avec cette carte de vol ?

J'ai test tous les protocoles et rien ne change :(

 

Merci d'avance

 

Share this post


Link to post
Share on other sites

oh là, tes ESC sont hors d'age, il y a de fortes chances qu'ils ne soient compatible qu'avec le protocole oneshot 125

Dans l'onglet configuration de betaflight, il faut basculer le protocole esc/moteur sur "oneshot" 125 et il faut les calibrer (qsi ça marche pas en one shot 125, essaye en pwm) le mieux serait de racheter des esc compatibles dshot

 

Share this post


Link to post
Share on other sites

A non tous les fils sont tj raccordé, j'ai donc deux gros fils directement alimenter par la platine du drones avec la lipo et une paire sur la carte contrôleur par moteur biensur.

Je dois donc retirer le gros rouge ?? Et alimenter l'esc directement par la carte de vol ? Je laisse le noir pour faire masse ?

Ou bien je remplace la paire qui vient de la carte de vol par celle qui est connectée sur la platine du drone ? 

Share this post


Link to post
Share on other sites

tu as les schémas de branchement de ta carte de vol ? 

L'esc est déjà alimenté directement sur la batterie (prise jst rouge). Le petit fil rouge est une alimentation qui envois du 5v dans la carte de vol. tu peux laisser la masse, pas de soucis. 

Share this post


Link to post
Share on other sites

Oui le schéma est posté plus haut dans le sujet.

J'ai donc bien mon esc raccorder en direct circuit de puissance et ensuite deux fils qui viennent de la carte de vol un noir et un blanc. Le petit fil rouge dont tu parles c'est lorsque le fil de commande à 3 fils je suppose. 

Par contre j'ai mesurer sur les bornes moteurs de la carte j'ai 11v tj présent quoi que je fasse avec la commande des gaz 

20191124_095440.jpg

Share this post


Link to post
Share on other sites

c'est effectivement le petit fil rouge sur la prise à 3 fils 

ESC 12A TB250 eTurbine - ETB-EC1

tu as fais la calibration des esc en pwm ? ça ne doit pas biper en discontinu, quand tu branchesla lipo tu as une séquence audio  et à la fin de la calibration, une autre petite série de notes...... 

Ensuite à chaque fois que tu vas brancher ta lipo, tu auras la mélodie entière qui initialise la carte. à mon avis,  la calibration n'est pas passée. 

Share this post


Link to post
Share on other sites

C'est pas gagner ^^

Je n'ai aucune mélodie lorsque je connecte la lipo juste un bip et un seul moteur qui fait un petit mouvement.

Les 11v sur les sorties de la carte c'est normale ou pas ?

Share this post


Link to post
Share on other sites

Je mesure la tension sur les 2 bornes + et - de la carte de vol la ou j'ai soudé les esc. 

Je vais commander de nouveaux esc je verrai bien après, merci encore pour ton aide et ta patience 

Share this post


Link to post
Share on other sites

Salut, bon ça progresse,

J'ai trouvé l'erreur la cf !!!

Défectueuse :( me disais bien étant donné que je n'avais pas de mélodie lorsque je branchais la lipo.

Donc j'en ai acheté une autre, une betaflightf4, j'ai tous bien programmé, les commandes du récepteur réagissent bien , les moteurs tournent lorsque j'essaie avec betaflight, l'aux pour l'armement est bien programmé et réagis correctement.

Par contre lorsque je déconnecte et que j'essaie avec la télécommande rien ne se passe. La led rouge de la cf réagis qd même mais pas les moteurs. 

La seule chose que je vois c'est que je n'ai pas raccordé les esc partie puissance sur la cf, j'ai en effet une distribution faite par le circuit imprimé de base prévu à cet effet.

Une piste ?? merci d'avance

Share this post


Link to post
Share on other sites
Il y a 14 heures, Anakroone a dit :

Défectueuse :( me disais bien étant donné que je n'avais pas de mélodie lorsque je branchais la lipo.

tu aurais commencé par là, on aurait gagné du temps. :blink:

Nous, derrière nos claviers, on est aveugles est sourds, si tu ne nous donnes pas toutes les infos, on part dans toutes les directions ..............

concernant le raccordement des esc à la carte, normallement, un seul fil par esc(le fil signal)  (voir 2 si la masse).

tu vas dans le cli et tu tapes la commande "status" , tu me donnes la dernière ligne d'info ("arming disable flags") 

Share this post


Link to post
Share on other sites

Salut, et merci pour ton aide

Je sais ce n'est pas facile lorsque l'on n'est pas en face, j'essaie de donner un max de détails ( ps: je l'avais noté plus haut, pas de mélodie lorsque je branche la lipo ! )

Bref: aucun soucis du côté cli : j'ai juste le cli et le mfs de noté donc logique étant donné que je suis connecté avec betaflight sur la cf.

Throttle, angle, arm etc fonctionne bien lorsque je les actives et que je fait un status.

 

Share this post


Link to post
Share on other sites

je pensais que tu avais changé les esc et que tu n'avais plus de soucis de mélodie. 

Si tu arrives à faire tourner les moteur les branchements doivent être bons. 

quand tu branches la lipo, la carte s'initialise bien jusqu'au bout ? (séquence complète de bips). tu es bien en dshot 600 ? 

 

 

Share this post


Link to post
Share on other sites




×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.